Symptom
- This document is one of the possible solution regarding unable to access Story reports while trying to create or run. Please check full details on KBA 2912865.
- Unable to access Story reports. Please ensure that third-party cookies are enabled in your browser settings, and try again. If the issue persists, please contact your system administrator to check the identity authentication settings and resolve the issue. For more information, refer to the Knowledge Base article 2912865.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
After successfully upgrading to Story reports in SuccessFactors and completing all implementation steps (such as user synchronization and permission assignment),
- Navigate to Report Center
-
Click New
-
Select Story
You may encounter either a blank or continuously loading screen, or an error message may be displayed.
Cause
The Login Name, Email or/and Custom Attribute of the user in IAS Profile does not match SuccessFactors BizX data.
BizX is connected to IAS via the BizX Username which is mapped to IAS Login Name. UUID from BizX corresponds to Custom Attribute in IAS.
All of these variables are used to authenticate users in SAC when logging into BizX through IAS.
Resolution
To fetch details from BizX:
- Login to SF
- Navigate to Reporting
- Create a new Table report based on Employee Profile domain
- Extract Username and UUID of the affected users.
You may also follow the instruction on this KBA:
2655941 - How to extract the Person GUID or perPersonUuid in SuccessFactors
To fetch details from IAS:
- Login to IAS
- Navigate to User > User Management and find the affected user
- Verify if the Login Name under Personal Information section matches the SF Username
- Scroll down to Custom Attribute section and verify if the value on relevant Custom Attribute (from SAC Subject Name Identifier) is same as the UUID on the report
If it is different, it might be an IPS sync issue. Please trigger a resync and check if the value gets updated (Syncing Users from SAP SuccessFactors HXM Suite to SAP Analytics Cloud). If it does not, then please reach out to support by creating a case for LOD-SF-PLT-IAS component.
If all of the above details are the same between BizX and IAS, then this is not the cause. Please follow next steps from the 2912865 KBA.
See Also
Keywords
story report, Blank loading screen, 3 dots, user sync, IAS, customAttribute1, UUID, Userid, username, Login Name, custom attribute, customattribute, subject name identifier , KBA , LOD-SF-ANA-SAC , Stories in People Analytics , LOD-SF-ANA-SAC-ADM , SF Admin configurations (Security Center, Provisioning) , LOD-SF-ANA-SAC-IAS , IAS configurations , Problem
Product
Attachments
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SAP Knowledge Base Article - Public