Symptom
After creating a user via a post request to the Users endpoint on tenants configured with a custom SAML IDP a welcome email will not be received.
Environment
- SAP Analytics Cloud (Enterprise) 2021.7.0
Reproducing the Issue
- Perform a GET request to <SAC-Tenant>/api/v1/scim/Users and include the following in the headers of the network request:
- Authorization: Bearer <access_token>
- x-csrf-token: fetch
- x-sap-sac-custom-auth: true
- Perform a POST request to <SAC-Tenant>/api/v1/scim/Users and include the following in the headers of the network request:
- Authorization: Bearer <access_token>
- x-csrf-token: <string> (found in the headers of the previous GET request)
- x-sap-sac-custom-auth: true
- Include the request body user schema to be submitted to the endpoint
{ "schemas": [ "urn:ietf:params:scim:schemas:core:2.0:User", "urn:ietf:params:scim:schemas:extension:enterprise:2.0:User", ] "userName":"<user@email.com>", "name": { "givenName":"<User_Given_Name>", "familyName":"<User_Family_Name>" }, "displayName":"<User_Display_Name>", "emails":[ { "value":"<user@email.com>", "type":"work", "primary":true } ], "roles":[], "groups":[], "urn:scim:schemas:extension:enterprise:1.0": { "manager": { "managerId": "" } } }
- Observe that despite the creation of the User to be successful there is no welcome email sent.
Cause
Tenants configured with a custom SAML IDP will not receive a welcome email.
Resolution
This is by design and the only way to receive email confirmation is to create a user manually or use a non custom SAML IDP. This will happen with users created using SCIM and SCIM2.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
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- SAP Analytics Cloud > Learning > Data Connections
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- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
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