SAP Knowledge Base Article - Public

3043764 - Welcome email not sent from SCIM User Provisioning API with a custom SAML IDP tenant in SAP Analytics Cloud (SAC) & SAP Digital Boardroom

Symptom

After creating a user via a post request to the Users endpoint on tenants configured with a custom SAML IDP a welcome email will not be received.

Environment

  • SAP Analytics Cloud (Enterprise) 2021.7.0

Reproducing the Issue

  1. Perform a GET request to <SAC-Tenant>/api/v1/scim/Users and include the following in the headers of the network request:
    • Authorization: Bearer <access_token>
    • x-csrf-token: fetch
    • x-sap-sac-custom-auth: true
  2. Perform a POST request to <SAC-Tenant>/api/v1/scim/Users and include the following in the headers of the network request:
    • Authorization: Bearer <access_token>
    • x-csrf-token: <string> (found in the headers of the previous GET request)
    • x-sap-sac-custom-auth: true
  3. Include the request body user schema to be submitted to the endpoint
    {
        "schemas": [
            "urn:ietf:params:scim:schemas:core:2.0:User",
            "urn:ietf:params:scim:schemas:extension:enterprise:2.0:User",
        ]
        "userName":"<user@email.com>",
        "name":
        {
            "givenName":"<User_Given_Name>",
            "familyName":"<User_Family_Name>"
        },
        "displayName":"<User_Display_Name>",
        "emails":[  
            {  
                "value":"<user@email.com>",
                "type":"work",
                "primary":true
            }
        ],
        "roles":[],
        "groups":[],
        "urn:scim:schemas:extension:enterprise:1.0": {
            "manager": {
                "managerId": ""
            }
        }
    }
  4. Observe that despite the creation of the User to be successful there is no welcome email sent.

Cause

Tenants configured with a custom SAML IDP will not receive a welcome email.

Resolution

This is by design and the only way to receive email confirmation is to create a user manually or use a non custom SAML IDP.  This will happen with users created using SCIM and SCIM2.

See Also

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Keywords

SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped, scim api, user provisioning api, custom idp, saml sso , KBA , LOD-ANA-AUT , SAC Authentication / Login , Problem

Product

SAP Analytics Cloud 1.0