SAP Knowledge Base Article - Public

3044882 - User Cannot Create Accounts

Symptom

You have a specific user that cannot create accounts, even if the user has all access restrictions maintained correctly.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers workcenter, Accounts view. 
  2. Click the "+" button to create a new account. 
  3. Fill all the required fields and click "Save and Open". 
  4. See that error message "You are not authorized to create accounts" appears. 

Cause

User has access restriction 1015 - Employee, Territory, Account, Sales Data maintained for Account workcenter, and just a few territories maintained for this access.

When creating a new account, action 'CreateSalesDataforMyEmployeeSalesResponsiblity' is called, assigning the newly created account sales data based on the Sales Responsibility defined for that employee.

After creation, the account will no longer be accessible for all users - just for those having the correct access restrictions.

Since user is restricted and does not have access to all territories, opening the account will not be possible.

The user does not have the necessary access to create this account.

Resolution

To maintain the same access restrictions and authorize user to perform the account creation, no sales data can be assigned to this user.

  1. Go to Administrator workcenter, Employee view. 
  2. Search for Employee 123 (123 represents the ID of affected employee) and click "Edit" button. 
  3. Scroll down to "Organizational Data" section. 
  4. At "Sales Data" pane, next to the Sales Organization maintained for this employee, uncheck the "Main" checkbox. 

Keywords

Cannot; Create; Account; Access Restrictions; Territory; Sales Data; , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 2102