Symptom
After a SAP tenant has been updated to wave 2021.10, the chart dialog which displayed a list of available hierarchies may no longer display all the hierarchies that were displayed prior to the wave update.
Pre-Patch List of Hierarchies
Post-Patch list of Hierarchies
(Note that 0BICS_CLOSED_INTERVA hierarchy is no longer displayed)
In addition, some charts which contain hierarchies may now show the error
"An error is preventing the chart from being displayed. Contact your administrator with the details"
Chart Error
The build panel for that chart will also show the error
"Selected hierarchy <Name of Hierarchy> was not found in the data source"
Chart Build Panel Error
After a data refresh, the error will change to
"Cannot find the following measures or dimensions or hierarchies in data source: <Name of Hierarchy>"
Chart Error
Environment
- SAP Analytics Cloud (Enterprise) 2021.10
Reproducing the Issue
- Create a story that uses a hierarchy prior to wave update
- Your tenant is updated
- The error now shows on some of the charts
Cause
In BW, every Hierarchy has a validity date (Valid from, Valid to) and every BW query has a KeyDate value. Depending on the KeyDate value, only the hierarchies which are valid for that keydate should be made available to use. There was a bug where the chart hierarchy dialog would show hierarchies that were not valid (outside their validity date range). This bug has now been fixed, and any chart which uses a hierarchy that should not have been made available will now show the errors listed above.
Resolution
There are two options to resolve this issue:
- Remove the problem hierarchy from the chart as it should not have been possible to pick that hierarchy in the first place.
- Talk to your BW administrator and have them modify the validity date of the hierarchy
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
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