SAP Knowledge Base Article - Public

3045744 - Visits Notes Not Synchronized from Cloud for Customer to Outlook

Symptom

You are adding notes to an already created Visit inside Cloud for Customer and after saving it is not synchronized to Outlook when using server side integration.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Environment

SAP Cloud for Customer

Cause

You have the Freeze Description Fields setting enabled in the Groupware settings. When this setting is enabled changes for description fields will not get synced after the first sync, when the event was created.

Resolution

Disable the option Freeze Description Fields in the groupware settings:

  1. Go to E-mail Integration Workcenter.
  2. Go to Groupware Settings View.
  3. Go to Settings tab. 
  4. At calendar configuration section disable the option Freeze Description Fields.
    CalendarConfig.png

Note: If this setting is already disabled and you still notice the issue, there is one other possible case. If two separate visits are created in C4C and Outlook with the same Subject and Start/End Time, Therefore, the sync component attempts to sync the C4C object to Outlook and the Outlook object to C4C during the sync session. It triggers deduplication mechanism that prevents duplicates creation. Once it is triggered, the sync component registers a conflict in the system which is expected and applies a resolution.

It is possible then for example that exchange wins the conflict and the original visit which did not have note maintained was picked to update the C4C visit with the rest of the values. Empty body for notes therefore overrides C4C notes.

Keywords

groupware, server side integration, visits, notes, sync, External Notes , KBA , LOD-CRM-GW-SCC , Invisible CRM - Smart Cloud Connect Solution , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2102

Attachments

CalendarConfig.png