Symptom
- DPCS Audit Report Showing Duplicated Records
- From the Data field you can see the time the users access the DPCS is different
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Manage Data Privacy Consent Statements
- Click View History
- Select "View Log" of the version you are working
- In View Audit Log, select the option View those whose treatment of this statement is: acceptance > Click Search
- On the right side of the page, Download detailed report
Cause
There are two reasons for the SF system to show duplicate records:
1) If the time gap between the date of two accept audit records is long, like in minutes or more, it mostly because there have one decline record between two accept records. If the user declined the DPCS, then they need to accept again in the next login
2) If the time gap between the date of two accept audit records is very short, like few seconds or the same, it mostly caused by the user click multiple times on accept button before the login page redirected
Resolution
This is expected behavior and there is no issue to be fixed.
For more details about the Data Privacy Consent Statements, you can access our Help Portal Guide:
Keywords
duplicate users, duplicate values, report, Data Privacy Consent Statements, manage DPCS , KBA , LOD-SF-PLT-DPC , Data Privacy Consent Statement (DPCS) Feature , How To