Symptom
You apply the filter combining the following status:
- Not Equal to Closed
- Not Equal to Canceled
- Not Equal to Completed
When exporting data using Data Workbench, you notice that the count is not consistent with the count in the object view with the same filter as shown above.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service workcenter
- Select the Tickets view
- Apply advanced Filter with filter: = !(=Closed; =Completed; =Canceled)
- Check Number of Records
Now
- Go to Data Workbench workcenter
- Select Export
- Select Service Request object
- Apply the Selection Conditions: Service Request.Status Code != AB - Canceled OR Service Request.Status Code != 6 - Closed OR Service Request.Status Code != 5 - Completed
- Compare Number of Records
You will notice the number of records is not the same in the above two situations.
Cause
Through DWB, using multiple 'Not Equal to' filters with same property but different values is not supported. Its not meaningful for the database fetch and it will give incorrect results.
In user interface, fetch with 'Not Equal to' is handled differently, this is the reason of the deviating results.
Resolution
Please use the Selection Condition 'Is Any Of' with selecting all the Status which you want to include.
See Also
SAP KBA 2377787 - Ticket Missing In The UI
Keywords
mismatch wrong number DWB , KBA , LOD-CRM-INT-API , OData API (C4C Only) , LOD-CRM-SRP , Service Request Processing , LOD-CRM-SRP-API , Ticket API & Odata , Problem