SAP Knowledge Base Article - Public

3049516 - Error HTTP 403 or 401 When Sending Data from Cloud for Customer to SAP ERP/CRM/S4H via Cloud Platform Integration

Symptom

When sending data from Cloud for Customer to SAP ERP/CRM/S4H via Cloud Platform Integration(CPI), the outbound message fails in C4C with error HTTP 403 or 401 (Forbidden/Unauthorized).

Environment

  • SAP Cloud for Customer
  • SAP Cloud Platform Integration 

Reproducing the Issue

  1. Login to C4C.
  2. Go to Web service Message Monitoring.
  3. Check the failed outgoing message with error "HTTP 500 Internal Server Error" or 401 (Unauthorized).
  4. Navigate to error log to see the full error text:  HTTP Code: 403 or 401 ( ) - An internal error occurred during message processing. 

Cause

The C4C Client (M) certificate has been renewed and/or the Root and Intermediate certificates of the C4C client certificate (M) are not available in the CPI keystore.

Resolution

  1. Download the client certificate (M-User certificate) from C4C Work Center: Administrator → Communication Certificates → Download Tenant Certificate.
  2. Upload the C4C client certificate in the CPI as mentioned in our blogs (NEO or CF): How to Setup Secure HTTP Inbound Connection with Client Certificates / How to Setup C4C M-user Client Certificate on Cloud Integration hosted on Cloud Foundry.
  3. Add the attached certificate (SAP Cloud Root CA) to the CPI keystore.

See Also

Online Help page: SAP Cloud Platform Integration

Keywords

CPI CERTIFICATE, C4C, HTTP, 403, 401, 500, Root, Intermediate, Unauthorized, CPI Keystore, M-User certificate , KBA , LOD-C4C-NET , Network Connectivity and Certificates , How To

Product

SAP Cloud for Customer core applications all versions

Attachments

C4C_root-certificate.zip