Symptom
The Customer Contract Invoice Request is in Status Inconsistent or Partially Inconsistent due to the Error:
Status of project task XYZ not 'Started', 'Released' or 'Completed' (XYZ stands for the Project tasks)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select Customer Contract Invoice Request ABC (ABD represents the ID of the Invoice Request).
- The status is Inconsistent or Partially Inconsistent.
- Click on the Check button.
- The following error is displayed for all or some items:
Status of project task XYZ not 'Started', 'Released' or 'Completed' (XYZ stands for the Project tasks)
Cause
A Project Task is assigned to the respective Items. When checking the respective Project Tasks you can see that these tasks have the status "Closed", which makes the Customer Contract Invoice Request inconsistent and blocks the Scheduled Invoice Requests from being created.
Resolution
To solve the issue you need to ensure that all respective Project Tasks have the 'Started', 'Released' or 'Completed'. Once you have changed this you can do the following:
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select the Customer Contract Invoice Request ABC.
- Click on the Check button.
- In the new window click on the Redetermine All button.
- Save you changes.
The respective Scheduled Invoice Requests will be created during the nightly run. You can also trigger the creation of the open Scheduled Invoice Requests manually:
- Go to the Customer Invoicing work center.
- Select the Invoice Requests view.
- Select the Customer Contract Invoice Request ABC.
- Click on the Edit button.
- Click on the You can also button.
- Select Create Scheduled Invoice Request.
Keywords
Contract; Invoice Request; Inconsistent; Partially Inconsistent; Project Task; Status , KBA , SRD-CRM-INV , Customer Invoicing , Problem