SAP Knowledge Base Article - Public

3050995 - Sales Order is in Status In Process but you Expect it to be in Status Completed

Symptom

 Sales order is in status In Process but you expect it to be in status Completed.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open sales order ABC (ABC represents the sales order number).
  4. Navigate to the Items tab.
  5. Select line item XX (XX represents the line item number).
  6. You can see that either the Delivery Status, the Invoice Status or both are not finished.

Cause

The Sales Order Item tab has two important statuses:

Delivery Status/Fulfillment Status and Invoice Status.

A Sales Order is only in status Completed if both status are set to Finished.

In case of a Sales Order for which none of the items are linked to a Project task:

  • for a material: The Delivery Status is set to finished when the Outbound Delivery is Released. 
  • for a service: The Fulfillment Status is set to finished once the Service Execution is Completed. 
  • for materials and services: The Invoice Status is set to finished when all Invoice Requests related to this Sales Order were invoiced and the Invoice is Released. 

In case of Sales Orders with Items linked to Project Tasks, the Delivery Status/Fulfillment Status and Invoice status has to be set manually to finished in Project because these are based on actual time recorded and the actuals could be equal or more than the planned amount in the Sales Order. In this case the Delivery Status is Finished when the assigend Project Task is Complete and the Invoice status is changed to Finish Invoicing.

However if the Item type is fixed price(project) and quantity is not equal to 1, then we expect the invoicing status to be set automatically to finish when invoices are done, but delivery status will still have to be manually finished.

Please note that with 2108: If the Customer Project Invoice Request was created via an Invoice Schedule for the Item of Item type fixed price(project) and all Invoice Schedule dates were invoiced, the Invoice Status in the Sales Order automatically changes to Finished.

Resolution

In case of Sales Orders with Items linked to Project Tasks:

Follow below steps to change the delivery status of the sales order to finished:

  1. Go to the Project Management work center.
  2. Select the Projects view.
  3. Open project XYZ via the Edit -> Project Plan button.
  4. Select the Basic Data sub tab.
  5. In the Project Status field select the Completed or Completed and Close option.

Follow below steps to change the Invoice status of the sales order to finished:

  1. Go to the Customer Invoicing work center.
  2. Select the Project Invoicing view.
  3. Select the Sales Orders sub view.
  4. Select sales order ABC.
  5. Press the Change Status button and select the Finish Invoicing button.

 Once  above is done then the Status of the related sales order ABC changes to Completed.

If the Change Status button is not enabled you can check if the Change Status button is enabled on the Items sub tab. If this is also not enabled, it is possible that you have open invoice schedules in the Sales Order. In order to select the Finish Invoicing option you need to ensure that all Invoice Schedules in the Sales Order are Invoiced. You can cancel any open Invoice Schedules in the Sales Order via the Cancel open dates option.

Using this action you can cancel all invoice schedule items that are in open status. 
If an unreleased invoice document exists for any open date then corresponding invoice request will change to status “With Conflict” and you can then cancel the invoice document. (See also KBA 2776630 - Customer Invoice Cannot be Released due to a Conflict detected in the Scheduled Invoice Request)

you can proceed as follows:

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Open Sales Order XYZ (XYZ represents the ID of the Sales Order).
  4. Navigate to the Pricing and Invoicing tab and the Invoice Schedule sub tab.
  5. Select the respective Item.
  6. Click on the Action button and select the Cancel open dates option.

See Also

2776630 - Customer Invoice Cannot be Released due to a Conflict detected in the Scheduled Invoice Request

Keywords

Status, statuses, delivery, project, change, completed, invoicing, invoice, facture, commande client, livraison, complétée, statut, Sales order status, , KBA , sales order, change status , finish invoicing , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions