SAP Knowledge Base Article - Public

3051071 - IPS sync failing - Unable to write entity to SAC due to Oauth request failed with status 401 unauthorized_client

Symptom

1. IPS sync is failing with the following error message:

error=com.sap.cloud.ips.connectors.api.ConnectorException: Unable to write entity to target system with name SAP Analytics Cloud - companyid - target Caused by: com.sap.cloud.ips.connector.exception.ProvisioningRuntimeException: Oauth request failed with status: 401 and body: {"error":"unauthorized_client"},
 
2. Customer asks to reset password for user "sac_tech_user" in properties tab for SAC Target in IPS

Environment

SAP SuccessFactors HCM Suite

Cause

The sac_tech_user from SAC target system in IPS has been changed.

Resolution

Customer needs to raise a ticket to LOD-SF-ANA-SAC.

Support team:

  • For CF tenants:

Support team needs to contact engineering team, they will share the password to be set in SAC target system in IPS.

 

  • For NEO tenants: 

Support team needs to contact engineering team, they will update the password. IPS admin access needs to be granted by the customer to the engineering team.

Keywords

IPS ERROR, SYNC, IPS, ERROR Sync, IAS Story, Story, IPS Story, Connector cannot process more entities due to irreparable error Caused by: Oauth request failed with status: 401 and body: {"error":"unauthorized_client"}, Header X-CSRF-Token not found among response headers , KBA , LOD-SF-ANA-SAC-IPS , IPS configurations and Sync Job , Problem

Product

SAP SuccessFactors HCM Suite all versions