Symptom
When in Account XYZ (XYZ represents account ID), Contacts facet, you want to add a new contact. However, you see that the "Add" button is missing.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Customer workcenter, Accounts view.
- Open Account XYZ and go to Contacts facet.
- Click in "More".
- See that "Add" button is missing.
Cause
You have restricted the number of allowed Account Assignments per Contact to 1.
With this set, it is no longer possible to assign a contact to more than one account. This means that all contacts having an account assignment can no longer be assigned. For that reason, "Add" button is disabled.
Resolution
Please, use the contact object to assign the account.
- Go to Customers workcenter, Contacts view.
- Open Contact 123 (123 represents contact ID).
- In header, fill the field "Account" with Account XYZ.
Note: If you follow all the steps suggested above and the issue is still unsolved, kindly check if the button is hidden via Adaptation Mode and unhide it.
Keywords
Add; Button; Disabled; Missing; Account; Contact; , KBA , LOD-CRM-ACC , Account , How To