Symptom
The Name field is writable despite adjustment via Layout to read only - Accounts work center.
Environment
Cloud for Customer
Reproducing the Issue
- Go to Customer > Accounts work center.
- Open any Account.
- Click on edit.
- Start adaptation.
- Make the field 'Name' read only under overview.
- End adaptation.
- Open the Account in edit mode.
- Click on Name pop up open where it is editable.
Cause
The pop up field needs to be made read-only from adaptation.
Resolution
- Open the Account screen.
- Start adaptation.
- Click Edit.
- Click on Name in header section.
- Now as shown in the screen-shot right click on the Pop up field name.
- Now click on back button in the right side adaptation pane.
- Navigate to the field properties.
- Now set the field property as read-only.
Keywords
adpatation, account, Name, read-only, editable, read, , KBA , AP-RC-UIF , C4C UI Framework , How To
Product
SAP Cloud for Customer core applications all versions