SAP Knowledge Base Article - Public

3052088 - Items in the billing document are in reverse order compared with items in the referred service contract

Symptom

In the billing document created with reference to a service contract, items are in reverse order compared with items in the service contract.

Environment

 SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. In the "Schedule Billing Document Request Creation" app, create three billing document requests (BDRs) for the three items of the service contract (assuming that there are three items in the service contract with the same billing date).
  2. In the "Create Billing Documents" app, these BDRs are displayed in reverse order in the billing due list, compared with items in the service contract.
  3. Select these BDRs and create a billing document.
  4. The items in the temporary invoice or the final invoice is also in reverse order compared with items in the service contract.

Cause

Billing due list items in the "Create Billing Documents" app are displayed in descending order of billing date by default. And if the billing due list items have the same billing date, they will be displayed in descending order of creation.

Resolution

  1. Click the "Settings" button on the top right corner of the "Create Billing Documents" app. 
  2. Under the "Sort" tab, choose "SD Document" and "Ascending".
  3. Then the billing due list items will be displayed in ascending order of billing date. If the billing due list items have the same billing date, they will be displayed in ascending order of creation.

Keywords

Billing Document, In Reverse Order, Descending, Ascending, Service Contract, Schedule Billing Document Request Creation, Billing Document Requests, Billing Date, Create Billing Documents, Billing Due List, Temporary Invoice , KBA , CRM-S4-SRV-CTR , S4CRM: Service Contract , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions