SAP Knowledge Base Article - Public

3052390 - Error Message: "Cannot convert blob:https://outlook.office.com/ID to Blob. Resource might not exist or is inaccessible." when Replying to E-mail

Symptom

You are replying to an e-mail from a Ticket and see error message "Cannot convert blob:https://outlook.office.com/IDto Blob. Resource might not exist or is inaccessible."

The error can occur for different clients other than Outlook (e.g., applewebdata).

Environment

SAP Cloud for Customer

Reproducing the Issue

  1.  Go to the Service work center.
  2. Select the Tickets view.
  3. Open Ticket ID XYZ (XYZ represents the Ticket ID).
  4. On the Interactions pane, click Reply to latest interaction:
  5. Errors are seen:

Cannot convert blob:https://outlook.office.com/ID to Blob. Resource might not exist or is inaccessible. (Here, ID represents the error code seen).

Cause

Those errors happen when the e-mail that is being replied to has broken inline images (their URLs for are specified as "blob:outlook-mobile-compose:///***").

These are not valid web URLs or base64 inline images. Hence when these are loaded into the TinyMCE editor, but when the agent tries to reply on them, the editor throws this message as it is unable to understand the inline image.

Resolution

This is the expected behavior of the system. The errors are thrown by the editor to indicate an issue with the images from the received e-mail.

The error message can be closed and the email reply can be sent just fine.

This error happens only on the TinyMCE editor, if you use Kendo, no error is seen.

Keywords

mail ; error ; microsoft ; outlook ; , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications all versions