SAP Knowledge Base Article - Public

3052906 - A field's value is visible in the user interface, but appears as null (blank) when queried via OData API or Integration Center - SAP SuccessFactors HXM Suite

Symptom

There's a field which has a value populated in the UI, but when querying it via OData or Integration Center, the value returned is null or blank.

NOTE: Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors HXM Suite

  • Employee Central

Cause

The field is transient or "pseudo-transient' (not an official term).

Resolution

Some standard fields in Employee Central are transient, which means that their value is always calculated and shown when viewed in the UI, but not stored in the database. Those fields cannot be queried by Integration Center or OData API.

Example: "compa-ratio" and "range-penetration" fields

Also, if a field has an onView rule associated to it, the field's value is also not stored and persisted in the database, and therefore if the field is queried by Integration Center or OData API, its value will always be null.

Example: custom field named "Years of Experience", with an onView and onInit rule that calculates its value:

   

Keywords

appear, visible, query, api, null, blank, field, transient, custom, rule , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , LOD-SF-INT-INC-ODATA , ODATA API In Integration Center , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

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