SAP Knowledge Base Article - Public

3053717 - Contract Activation, Renewal or Termination for a Contract or Contract Items is Not Executed as Expected

Symptom

The Contract Activation, Renewal or Termination for a Contract or Contract Items is not executed by the System as expected.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. We will use the example of a Contract Item Renewal.
  2. Go to the Sales Orders work center.
  3. Select the Contracts view.
  4. Open Contract XYZ (XYZ represents the ID of the Contract).
  5. Navigate to the Items tab.
  6. Select Line Item XX (XX represents the line item number).
  7. In the Details tab you can see that a Renewal Rule was maintained and according to the parameters in the Rule and the Contract Item End Date the item should have been renewed but this did not happen.

Cause

The system creates Business Tasks (BTM Task) for Contract Activation, Renewal or Termination of a Contract or Contract Items.

These Tasks can fail to be executed by the system due to errors/inconsistencies.

For example because the Product is blocked or the Document is locked

In these cases the error is stored in an Application Log.

These BTM Tasks are visible in the Application and User Management work center and the Business Task Management view and the Application Log with the respective errors can be accessed there.

We now also enabled this in the Contracts view for the Employees to access and check these errors directly, check the Application Log, solve the respective issue reported in the error and then Reschedule the BTM task again.

Resolution

The Automated Tasks and the Application Logs can checked as follows:

  1. Go to the Sales Orders work center.
  2. Select the Contracts view.
  3. In the drop-down list select Automated Tasks with Errors
  4. Select the respective task Automatic Renewal of Contract Item XYZ - XX
  5. Open the Application Log to see the error details.
  6. Once the cause of the error is solved, select the task and click on the Reschedule Button.
  7. If you do not see an Application Log in the Application Log section the issue could already be solved and you can also click on the Reschedule Button.
  8. The Tasks is rescheduled by the system and you can check the results after some time.

If the task reappears please create an incident with the details such as Contract, Item and the Subject of the Task.

See Also

KBA 2465356 - Contract Renewal not Triggered

KBA 2723677 - Contract Items are not Renewed Correctly

Keywords

Contract; Automatic Termination; Automatic Renewal; Automatic Activation; Validity; Not Started; Renewal Rule; Contract Start Date; Contract End Date; Contract Item Start Date; Contract Item End Date; , KBA , AP-CCP-CC , Customer Contract , Problem

Product

SAP Business ByDesign 2011 ; SAP Business ByDesign 2105 ; SAP Business ByDesign 2108