SAP Knowledge Base Article - Public

3053794 - How to add remarks/notes in Email address using API_BUSINESS_PARTNER

Symptom

How to add remarks/notes using element 'AddressCommunicationRemarkText' and entity 'A_BusinessPartner' in API - API_BUSINESS_PARTNER? 

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open SAP Gateway Client
  2. Enter the URL, paste request information 
  3. Response 201, generated a new BP number xxxxxxx
  4. Open "Maintain Business Partner" app and find BP xxxxxxx
  5. Navigate to Communication -> E-mail -> "Note" field is blank

Cause

Language parameter is not passed in the URL. 

Resolution

The field 'Notes' of E-mail is language dependent and there is no automatic translation for this field. The communication user always logs on with system language which is usually English. The default language of the communication user cannot be changed. But when calling an API , the language can be passed with which the communication user logs on to the system. To do so you, pass language when calling the API by adding the parameter for the language to the URL. 

Sample URL: /sap/opu/odata/sap/API_BUSINESS_PARTNER/A_BusinessPartner?sap-language=IT 

Keywords

S4_PC, HANA, CLOUD, API, API_BUSINESS_PARTNER, Language, Remarks, Notes, Email Address, OData  , KBA , LO-MD-BP-ODT , OData Service for Business Partner , How To

Product

SAP S/4HANA Cloud 2102