Symptom
When you associate a lead to an account that is obsolete account becomes active.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: Business configuration scoping question "Do you want to include obsolete business partners in the duplicate check?" is included in the project.
- Go to the Leads work center.
- Open lead ABC (where ABC is the ID of a lead that can be associated to account and contact).
- Click in the Actions button and select Associate to Account and Contact.
- In the duplicate check section, select account DEF from the list (where DEF is an account with column 'Status' as 'Obsolete'; you might need to include this via adaptation mode).
- Click in Save and then select Save and Open.
Account DEF status is now 'Active'.
Cause
This is the system current standard behavior. If you are creating a lead you want to make business with an account later on. When you associate this lead to an account the system understands that this account can make business with you once again and for that it should be active.
Resolution
If you want to avoid this mistake you can make the system not show obsolete accounts during duplicate check.
- Go to the Business Configuration work center.
- Open the Implementation Projects view.
- Select the current implementation project and click in the Edit Project Scope button.
- Go to step 4 'Questions' by clicking in the Next button three times.
- Expand 'General Business Data -> Business Partners -> Handling of Business Partners'.
- Look for question "Do you want to include obsolete business partners in the duplicate check?" and make sure its checkbox "In Scope" is not checked.
- Go until step 6 'Confirmation' and save your changes.
Keywords
Leads ; Lead ; Associate to Account and Contact ; Obsolete ; , KBA , LOD-CRM-LM , Lead Management , LOD-CRM-ACC , Account , How To