SAP Knowledge Base Article - Public

3053870 - Exception Occurs in Live Activity Configuration When You Try to Add a New Object

Symptom

An exception occurs in Live Activity Configuration when you try to add a new Object under "Search Objects".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Administrator Workcenter.
  2. Navigate to Service and Social view.
  3. Go to "Live Activity Configuration".
  4. Under "Search Objects", click "Add".
  5. The error "500 SAP Internal Server Error" is shown.

Cause

This exception is happening because the Provider is blank.

Resolution

"Provider" is a mandatory field on the screen.

In order to solve this issue, you have to maintain a Provider before proceeding to add the Objects. Please, follow the steps below:

  1. Navigate to Administrator Workcenter.
  2. Navigate to Service and Social view.
  3. Go to "Live Activity Configuration".
  4. Under "Communication Provider" you will see the field "Provider".
  5. Click on the drop down and select your provider. 

After following the steps above, you will be able to add an Object and the exception won't occur anymore.

Keywords

Exception ; Live Activity Configuration ; Objects ; Provider ; Dump ; Error , KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer add-ins all versions