Symptom
You notice that, after confirming a contact during an inbound call, the Caller field is filled with an unexpected contact account name.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Perform an inbound call to your tenant.
- See the contact ABC (ABC being the contact name) is identified.
- The contact account displayed for contact ABC is XXX (XXX being the contact account name).
- Click to confirm the contact.
- See the field Caller is filled with contact account YYY (YYY being another contact account name).
Cause
This happens in case the contact ABC is maintained as Main Contact for contact account YYY, although the contact account XXX is displayed during the inbound call.
The system will always display the main contact account for a specific contact.
Resolution
This is the system expected behavior.
In case you would like to show a different contact account, it is required to change the Main Contact assignment for the contact ABC.
Keywords
CTI, Live Activity, Caller, Account, Details, Unexpected, C4C, Cloud for Customer, Service, Wrong Account, Field, Contact, Contact Account, Main Contact, , KBA , LOD-CRM-LA , Live Activity , How To