SAP Knowledge Base Article - Public

3055064 - Exception in UI Component after binding an Action

Symptom

You can see an exception thrown in the UI on loading a UI Component after you have bound a Business Object (BO) Action.

Environment

  • SAP Business ByDesign
  • SAP Cloud Applications Studio
  • SAP Cloud for Customer

Reproducing the Issue

Prerequisites:

  • You have created an Add-On Solution.
  • You have enhanced a screen with an Action using the Extensibility Explorer in the UI Designer.

Steps to reproduce:

  1. Log into the system UI with a Business User.
  2. The exception is thrown immediately when the UI Component is being loaded in the UI.

Cause

Case 1:

The Action in the binding no longer exists on the BO.

Case 2:

The Action is bound via a Virtual Association (VA) path, for example, actionPath="Root-.[SalesDocuments]-.CustomerQuote->doThis" in the XML (where Root refers to the Opportunity BO and [SalesDocuments] is the VA).

Resolution

Case 1:

Check that the Action binding is correct and reactivate BO and rebind on the UI Component if required.

Case 2:

VA actionPath is not supported by the system as it expects to find the action directly on the Opportunity-BTDReference Node.

Keywords

PDI, SDK, UI Designer, Virtual Association, actionPath, [SalesDocuments], Extensibility Explorer , KBA , AP-RC-UIF , C4C UI Framework , AP-RC-UIF-DT , UI Framework Designtime , Problem

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions