Symptom
When dealing with a scenario of Pro Forma Invoice creation with a Split in the Invoice, you notice that different templates are being determined for each Split document.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to the Sales Orders work center.
- Open the Sales Orders view.
- Find Sales Order ABC (Where ABC Represents the ID of a Sales Order where a Pro Forma Invoice Split will happen).
- Highlight it and click on the Pro Forma Invoice button.
- In the Pro Forma Invoice Split Analysis screen, select one of the Invoices and click on the Print Pro Forma Invoice button.
- The system will determine template DEF and use it in the Preview.
- Now, select a different Invoice and click on the Print Pro Forma Invoice button.
- The system will determine template GHI, a different one than the previous.
(DEF and GHI Represent different template IDs).
Cause
The different determination will happen because there are different Tax Countries maintained between the Items in the Sales Order.
Resolution
This is the expected system behaviour. The system will determine each template separately for each item, and if there is a discrepancy in the Tax Country maintained in that item, that will be taken into consideration for the determination and result in the selection of a different template.
See Also
2038600 - While Selecting the Print Pro Forma Invoice From a Sales Order, the System is Selecting a Different Form Layout
2591499 - Error Message 'Form template variant Customer Invoice for language ABC and country DEF cannot be found'
Keywords
Pro Forma, Proforma, Template, Incorrect, Inconsistent, Different, Split, Country, Language , KBA , AP-CI-CI , Customer Invoice , AP-RC-OUT , Output Management , How To