SAP Knowledge Base Article - Public

3057110 - Apply with LinkedIn not Showing Up on Career Site - Recruiting Marketing

Symptom

  • I've enabled LinkedIn in Career Site Builder > Tools > Social Apply but the option doesn't show for candidates;
  • Candidates unable to apply with LinkedIn;
  • LinkedIn disappeared for candidates;
  • Apply with LinkedIn disappeared from the career site.

Environment

SAP SuccessFactors Recruiting Marketing

Cause

Possible causes:

  • Cookie Banner in Cookie Manager tab has been enabled in CSB and corresponding cookie section has not been enabled to add the Cookie Provider.
  • Subscribe at apply setting is set to false in the XML file
  • Social Apply is not enabled for Linkedin

Resolution

Cookie Banner in Cookie Manager tab has been enabled in CSB and corresponding cookie section has not been enabled to add the Cookie Provider.

  • Once Cookie Banner is enabled in Cookie Manager tab in CSB it is necessary to include the Cookies associated to the features in the corresponding cookies sections in Cookie Manager tab.
  • Refer to the section Configuring the Career Site Cookie Banner and Cookie Consent Manager of the Recruiting guide for more information on how to use cookie consent manager.
  • If  any element or component is included to the career site that uses cookies, make sure to add its listing in the cookie consent manager so that the component works correctly. 

Take the Following Steps :

  1. Navigate to Career Site Builder;
  2. Appearance > Global > Cookie Manager tab;
  3. Enable Advertising Cookies Section;
  4. Add the Cookie Provider LinkedIn.

Subscribe at apply setting is set to false in the XML file

Please take the following steps:

  1. In Career Site Builder, go to Tools
  2. Select "Import & Export"
  3. Select "Site Settings"
  4. Click on Export
  5. In the XML file, search for subscribeatapply
  6. You will see this is set to false
  7. Set it to true
  8. Save the file
  9. Import this file to CSB

Social Apply is not enabled for Linkedin

Please take the following steps:

  1. In Career Site Builder, go to Tools
  2. Select "Social Apply"
  3. Set the Linkedin option to On

See Also

KB Article - 3046470 - Enhanced Cookie Management Settings in Career Site Builder - Recruiting Marketing

KB Article - 2848667 - How To Troubleshoot Apply with Linkedin 2.0 - Recruiting Management

Keywords

RMK, Recruiting Marketing, Cookie, Missing, Apply with LinkedIn, Disappeared, Cookie Manager, Troubleshoot, Linkedin 2.0 , KBA , LOD-SF-RMK-CSB , Career Site Builder , Problem

Product

SAP SuccessFactors Recruiting all versions