SAP Knowledge Base Article - Public

3057179 - Error "SoapFault:faultstring=MustUnderstand headers" on the CPI during Business Partner replication

Symptom

When replicating Business Partner from SAP Cloud for Customer, you can see the following error in the SAP Cloud Platform Integration message monitoring:

Inbound processing in endpoint at /C4C/yMKT/BusinessPartnerReplicationSelfInitiatedOut failed with message "SoapFault:faultstring=MustUnderstand headers: [{http://www.w3.org/2005/08/addressing}Action, {http://www.w3.org/2005/08/addressing}To] are not understood.; faultcode={http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand"

Environment

  • SAP Cloud for Customer
  • SAP Cloud Platform Integration

Reproducing the Issue

  1. Trigger the replication of Business Partner from C4C.
  2. Go to the Administrator work center.
  3. Go to the General Setting work center view.
  4. Open the Web Service Message Monitoring under System Administration
  5. Select Erroneous.
  6. Filter by Service Interface BusinessPartnerReplicationSelfInitiatedOut.
  7. On the C4C you can see the error: HTTP Code: 500 ( Internal Server Error )
  8. Go to the CPI Monitor Message Processing 
  9. Search for the failed "Replicate Business Partner to SAP Business Suite" message

Error Details
Inbound processing in endpoint at /C4C/S4/BusinessPartnerReplicationSelfInitiatedOut failed with message "SoapFault:faultstring=MustUnderstand headers: [{http://www.w3.org/2005/08/addressing}Action, {http://www.w3.org/2005/08/addressing}To] are not understood.; faultcode={http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand"

Cause

The cause might be:

  1. The C4C Communication System is not configured as expected or
  2. The Communication Arrangement was not Saved and Reactivated.

Resolution

The resolution of the error can be:

  • The C4C Communication System is not configured as expected
  1. Go to the Administrator Work Center.
  2. Navigate to General Settings work center view.
  3. Open Communication Systems under Integration division.
  4. Open the communication system which is created for C4C-Marketing integration.
  5. Set the "Preferred Application Protocol" to "5 - Web Service".

  • The Communication Arrangement was not Saved and Reactivated
  1. Go to the Administrator Work Center.
  2. Navigate to General Settings work center view.
  3. Open the Communication Arrangement Business Partner Replication to SAP Business Suite
  4. Click on "View All"
  5. Click on "Save and Reactivate" button.

Keywords

soap:MustUnderstand C4C INTEGRATION, C4C, Cloud for Customer, CPI, SoapFault:faultstring=MustUnderstand, MustUnderstand, Business Partner, Account, Individual Customer, Customer. , KBA , LOD-CRM-INT-YMT , Integration of C4C with Marketing , How To

Product

SAP Cloud for Customer core applications 2102