Symptom
When replicating accounts from SAP Cloud for Customer to SAP Marketing Cloud, you see the following error in the SAP Cloud Platform Integration message monitoring:
Inbound processing in endpoint at /C4C/yMKT/BusinessPartnerReplicationSelfInitiatedOut failed with message "SoapFault:faultstring=MustUnderstand headers: [{http://www.w3.org/2005/08/addressing}Action, {http://www.w3.org/2005/08/addressing}To] are not understood.; faultcode={http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand"
Environment
SAP Cloud for Customer
SAP Cloud Platform Integration
Cause
The C4C Communication System is not configured as expected.
Resolution
- Log on to SAP Cloud for Customer.
- Go to the Administrator Work Center.
- Navigate to General Settings work center view.
- Open Communication Systems under Integration division.
- Open the communication system which is created for C4C-Marketing integration.
- Set the "Preferred Application Protocol" to "5 - Web Service".
Keywords
soap:MustUnderstand C4C MKT INTEGRATION , KBA , LOD-CRM-INT-YMT , Integration of C4C with Marketing , How To