Symptom
When replicating Business Partner from SAP Cloud for Customer, you can see the following error in the SAP Cloud Platform Integration message monitoring:
Inbound processing in endpoint at /C4C/yMKT/BusinessPartnerReplicationSelfInitiatedOut failed with message "SoapFault:faultstring=MustUnderstand headers: [{http://www.w3.org/2005/08/addressing}Action, {http://www.w3.org/2005/08/addressing}To] are not understood.; faultcode={http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand"
Environment
- SAP Cloud for Customer
- SAP Cloud Platform Integration
Reproducing the Issue
- Trigger the replication of Business Partner from C4C.
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration
- Select Erroneous.
- Filter by Service Interface BusinessPartnerReplicationSelfInitiatedOut.
- On the C4C you can see the error: HTTP Code: 500 ( Internal Server Error )
- Go to the CPI Monitor Message Processing
- Search for the failed "Replicate Business Partner to SAP Business Suite" message
Error Details
Inbound processing in endpoint at /C4C/S4/BusinessPartnerReplicationSelfInitiatedOut failed with message "SoapFault:faultstring=MustUnderstand headers: [{http://www.w3.org/2005/08/addressing}Action, {http://www.w3.org/2005/08/addressing}To] are not understood.; faultcode={http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand"
Cause
The cause might be:
- The C4C Communication System is not configured as expected or
- The Communication Arrangement was not Saved and Reactivated.
Resolution
The resolution of the error can be:
- The C4C Communication System is not configured as expected
- Go to the Administrator Work Center.
- Navigate to General Settings work center view.
- Open Communication Systems under Integration division.
- Open the communication system which is created for C4C-Marketing integration.
- Set the "Preferred Application Protocol" to "5 - Web Service".
- The Communication Arrangement was not Saved and Reactivated
- Go to the Administrator Work Center.
- Navigate to General Settings work center view.
- Open the Communication Arrangement Business Partner Replication to SAP Business Suite
- Click on "View All"
- Click on "Save and Reactivate" button.
Keywords
soap:MustUnderstand C4C INTEGRATION, C4C, Cloud for Customer, CPI, SoapFault:faultstring=MustUnderstand, MustUnderstand, Business Partner, Account, Individual Customer, Customer. , KBA , LOD-CRM-INT-YMT , Integration of C4C with Marketing , How To
SAP Knowledge Base Article - Public