SAP Knowledge Base Article - Public

3057189 - Error: Technical error AP_ESI_COMMON 107; report an incident

Symptom

This error can be seen anywhere in Business ByDesign.

Environment

SAP Business ByDesign

Cause

This is a generic error message that is caused by Customizations done by your partners.

Resolution

You have either PDI Add-on's/customizations/ custom extension fields in your system that may or may not be directly linked to this issue, which could be causing this issue.

A.If the issue happens in your test tenant, or in production tenant but your test tenant has similar environment, ask your partner to switch off all PDI Add-on's in test tenant first, then reproduce once again.

  1. If you face no such issue after switching off the PDI's, then it means PDI is causing problem, please contact your partners to find the cause and help fix the issue.
  2. If you still face issue after switching off the PDI's, then let us know by giving permission to skip the PDI's while we reproduce the issue with our Support user. Also provide the URL, steps, document ID and permission to reproduce the issue.

B. If the issue only happens in production tenant and you cannot switch off PDI's, you can also troubleshoot the issue by tracing in SDK for the production tenant.

  1. If Add-on's found in the trace log, please contact your partners to check the respective Add-on and fix the issue.
  2. If no Add-on's found in the trace log, then let us know by providing the URL, steps, document ID and permission to reproduce the issue with our Support user. 

See Also

KBA: 2365114 - How to take trace in the Cloud Application Studio SDK
Community Blog: Performance ABSL Trace – New functionality in 2005 Release.
Help Document: Tracing Quick Guide

Keywords

Technical error AP_ESI_COMMON 107; Add-on; PDI , KBA , ap esi common error , ap_esi_common , SRD-SRM-PRO , Purchase Requests and Orders , AP-RC-BDS-LM , ByDesign Studio Lifecycle Management , Problem

Product

SAP Business ByDesign all versions