Symptom
The candidate/user update or field/s change do not show on Job Application History.
Specific field on candidate application modified not being recorded in Job Application History.
Environment
Successfactors - Recruiting Management (RCM)
Reproducing the Issue
1. As candidate, login to career site
2. Go Jobs Applied
3. Open any job applied
4. Edit any field
5. Click save
6. As Recruiter, go to Recruiting
7. Select the job requisition that candidate has applied
8. Open the candidate application
9. Go to take Action > History
10. Notice that modification in application is not captured in the history.
Cause
By system designed the readOnly should always set to readOnly="false" to capture the audit properly.
Resolution
In Job Application XML Template or Manage Recruiting Templates in Admin Center.
Navigate to field ID or in XML template the code block then, validate the readOnly attribute should set to readOnly="false"
Sample Code
<field-definition id="firstName" type="text" required="true" custom="false" public="false" readOnly="false" anonymize="true">
The readOnly attribute specifies the field as a read-only field. This is generally a legacy attribute. Read/Write capability is now typically controlled through permissions and not using this attribute. In a new configuration, always set this attribute to false.
See Also
2478860 - Fields Not Visible in Candidate History After Applicant Change - Recruiting Management
Implementation Guide : Job Application Field Definition: Attributes
Keywords
Missing, Audit, Changes, Application, History, INC0681194 , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem