Symptom
Integration center Jobs are failing with an error:
"Failed due to - Index: 0, Size: 0"
This error can be seen in Event log of Execution Manager
Cause
Calculated Filter's output is zero
Resolution
This issue occurs only when there are zero records to be processed post calculated filter applied for each batch.
Example:
case 1. Destination batch size is 1000. Total number of records read by starting entity is 900. So, there will be only one batch of records to be processed and written back to SF. However, if all these 900 records are being filtered out by Calculated filter and there is no record to be written back to SF then Integration fails. In this scenario, there is no business impact as there was no data to be processed anyway.
case 2: Destination batch size is 1000. Total number of records read by starting entity is 1500. So, there are 2 batches to be processed. if first batch returns more than 1 record after calculated filter then first batch will be processed successfully. However, if second batch returns 0 records then batch 2 will fail, the job will be marked as failed. In such a case, no business impact and no data loss.
Case 3: In the above case, if the first returns 1+ record, second returns 0 and 3rd batch would have returned 1+ record, in such a case, batch 3 will not get processed and there will be data loss.
This issue in known now to our Engineering team and fix will be applied with our very first patch which is scheduled on 28th May.
Keywords
KBA , LOD-SF-INT-INC , Integration Center , Problem