SAP Knowledge Base Article - Public

3060161 - Error when creating stories in C4C: We couldn't connect to your HANA system

Symptom

You are using Embedded SAC in your C4C system. When trying to create a new story, you face the following error:

We couldn't connect to your HANA system. Please ask your administrator to check that third-party cookies are not blocked, and that CORS is configured correctly.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the work center Business Analytics and the view Design Stories.
  2. Click New.

You receive the error above.

Cause

The Single Sign-On setup has not yet been completed in your system.

Resolution

  1. Go to the work center Administrator and the view Common Tasks.
  2. Click Configure Single Sign-On.
  3. Make sure that all required information is maintained here.
  4. Click Activate Single Sign-On once all settings are done. 

See Also

When choosing a IdP Subject Name Identifier in C4C and in IdP, note that the user / e-mail you enter is case sensitive.

For further details, please see the following KBA 3279276 - User Activation Failed Error in Embedded SAC (C4C).

Keywords

SAP Analytics Cloud, embedded, stories, We couldn't connect to your HANA system, Cors, third party cookies, error message, SSO, single sign on , KBA , AP-RC-ANA-SAC , C4C, ByD: SAC Integration , How To

Product

SAP Cloud for Customer core applications all versions