SAP Knowledge Base Article - Public

3061371 - Error: Base UOM is missing While Importing Competitor Products in Data Workbench

Symptom

You are trying to import Competitior Products using Data Workbench and you receive below error

Base UOM is missing

Reproducing the Issue

  1. Go to Data Workbench
  2. Select Import view
  3. Insert Complete BO option
  4. Search and select Competitor Products
  5.  Select your excel file and upload

Above error occurs on screen.

Cause

You have added various field named Product Category at different places:

In the Competitor Product UI to BO Node Material - Competitor Information, field ProductCategory

In Product Administration UI to BO Node Material - Common, Field XXXXX (where XXXXX is a field in Common Node of Material)

Product UIs, so the competitor as well as the normal product, are based on the same BO Material (PDM_MATERIAL).
This is also the case for Product oData services, which are also reusing the same, technical BO.

BUT:

 The COMMON Node, which is used in the Product Administration, is not used in the oData for Competitor Product like the COMPETITOR_PRODUCT (Information) node is not used for normal products.

If you check now the first field ProductCategory is not added to the corresponding oData competitorproduct, while second field XXXXX, which was added in the Product Administration UI, is  added to the competitorproduct oData. This means, that the field Product Category send in the oData is not supposed to be used for Competitor Products.

ProdAdmin.PNG

Resolution

To solve this issue, you should remove the usage of second field XXXXX, from the oData competitorproduct and therefore add first field ProductCategory to it.

Keywords

KBA , LOD-LE-PRD-PRD , Product + Product Category Hierarchy , Problem

Product

SAP Cloud for Customer core applications all versions