Symptom
You check the Service Order after performing all the necessary steps and find the Customer Demand missing.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Service Order Work Center.
- Go to Service Order Processing view.
- Search for XYZ (XYZ refers to the Service Order ID).
- Go to the document flow and the Customer Demand is missing.
Cause
The Service Order was created with the item type "Spare part - direct goods issue". Items of this type are not shipped, but are either brought by the engineer to be used directly on site, or are available to be used at own service center. For Service Order XYZ, the Location of Service Provision is "Own Service Center" and so no shipment is required, and no customer demand will be generated.
Resolution
If spare parts need to be sent out in advance, kindly cancel the Service Order and create a new one using a different item type for the spare parts.
See Also
2968878 - Customer Demand Not Created from Service Order
Keywords
"Service Order", "Spare Parts", "Customer Demand", "Spare part - direct goods issue" , KBA , AP-SLO , Sales Order Processing , Problem