Symptom
Class Registration Emails are still sent even if all the Class-level Email notifications have been set to No.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Assign/ Register a Class to a user.
- User receives notification email on registration of a Class.
- Following settings are maintained on Class-level but still receiving the email notification:
a. Go to Learning Activities --> Classes.
b. Search and Open the affected Class.
c. Under Details section, all the email Confirmations are set to No under following sections:
Email Confirmation for Admin-Initiated Actions
Email Confirmation for User-Initiated Actions
d. Still E-mails are getting generated.
<This is for expiration. KBA still in progress to find solution>
Cause
Item level settings for Email notification are overriding the Class-level settings.
Resolution
- Go to Learning Administration
- Click Items under Learning Activities.
- Search for the item you want to disable the notifications.
- Click on Edit.
- Go to "Email Notifications" tab.
- Un-check "User" / "Manager" Under "Override Learning Expiration Email Notification Defaults" in Email Recipients according to business requirement.
- Click "Apply Changes".
See Also
Keywords
LMS, class-level, item, notification, e-mail, notification text, edit, tab, learning plan expiration, sf, success factors, email, mails, headers and footers, turn, off, on, override, automatic, manual, turn, no, deny , KBA , LOD-SF-LMS-NOT , Notifications , Problem
Product
SAP SuccessFactors Learning all versions