Symptom
While doing invoice you may find entries under "All Deliveries To Be Invoiced" or "All Returns To Be Invoiced" for which you are unable to invoice because of error messages.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Supplier Invoicing work center.
- Go to Invoice Entry view.
- Show: "All Deliveries To Be Invoiced" or "All Returns To Be Invoiced".
- Search for ABC (ABC is the Delivery ID or the Return to Supplier ID).
- If ABC is a delivery, click in New Invoice button.
- If ABC is a return, click in New Credit Memo button.
Cause
By default, these queries "All Deliveries to Be Invoiced" or “All Returns To Be Invoiced" were developed to show all Deliveries and all Returns, respectively. So, even if the Inbound Delivery was already returned, the user is still able to see the inbound delivery under "All Deliveries to Be Invoiced". That's why when the user is trying to create the Supplier Invoice, it is triggered the Exception “The system has created an exception because the receipt document is missing or invalid. Process the corresponding exception.”
Even if the Inbound Delivery was not invoiced and already delivered, but without the creation of the Credit Memo yet, the Supplier Return will still be available in the "All Returns to be Invoiced" query. When the user tries to create the Credit Memo, the system trigger the error message "Nothing open for invoicing for purchase document XYZ".
Resolution
The system is working as designed. Even if those documents are not available for invoicing, they will still show under the queries "All Deliveries to Be Invoiced" or “All Returns To Be Invoiced".
If you think that the system should behave differently, you can still submit your idea in our Customer Influence Forum: https://influence.sap.com/sap/ino/#campaign/886
See Also
Keywords
Supplier Invoice; Query; Return to Supplier; Inbound Delivery; Exception , KBA , SRD-SRM-SI , Supplier Invoicing , How To