SAP Knowledge Base Article - Public

3062007 - Extension field showing wrong value in the  Over-the-Counter Sale. 

Symptom

 Extension field "XYZ" showing wrong value in the  Over-the-Counter Sale.

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. Go to Over-the-Counter Sales work center -> Over-the-Counter Sales view. 
  2. Select New Over-the-Counter Sales with Product ZZZ (ZZZ represents the Product ID).
  3. Under Items tab system shows the default value of the extension field.
  4. But in the product master data value maintianed is different. 

Cause

Since Over the counter sales is an Invoice request document, you need to activate the extension scenario from Material - General Information to Customer Invoice Request - Item Information.

Resolution

Kindly activate the extension as below.

  1. Go to Over-the-Counter Sales - Over-the-Counter Sales
  2. Go to New Over-the-Counter Sale
  3. Hover over Key User Settings and click Start Adaptation Mode.
  4. In the top-right of the screen, click on the button with your profile picture.
  5. Go into Adaptation Mode.
  6. In the side bar, scroll down until you see a plus ('+') sign.
  7. Click on it and select Extension Fields.
  8. Highlight the extension field that is you want to extend to Invoice Requests.
  9. Click on Further Usage.
  10. Go to the tab Extension Scenario.
  11. Select Material - General Information to Customer Invoice Request - Item Information
  12. Click on "Add Field"
  13. Save and Publish the changes.

Keywords

KBA , SRD-CRM-INV , Customer Invoicing , Problem

Product

SAP Business ByDesign all versions