SAP Knowledge Base Article - Public

3062432 - Workflow Rule with End Customer for Ticket Determination Does Not Send E-mail

Symptom

You notice that a workflow rule which uses the End Customer for Ticket determination does not send any e-mails for your tickets.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Service work center.
  2. Navigate to Tickets work center view.
  3. Open any ticket.
  4. Click Edit.
  5. Perform any change (as per your rule conditions).
  6. Save the changes.
  7. Navigate to Workflow Changes tab.
  8. See the workflow rule is not triggered.

Cause

The determination End Customer for Ticket does not return a valid recipient for the ticket.

The End Customer for Ticket is an Individual Customer, while the Contact of Account or Individual Account of Ticket is the main contact for any of these parties.

Resolution

It is required to maintain a main contact to the account which is linked to the ticket you would like the rule to trigger.

Keywords

Ticket, Workflow, Workflow Rule, Service Ticket, Determination, End Customer for Ticket, Valid Recipient, Recipient, C4C, Cloud for Customer, Account, Contact, Individual Customer, Contact of Account, Individual Account, Party, Main Contact, Main, , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions