Symptom
Error when trying to renew SAC subaccount certificate in SAP Cloud Connector.
Environment
- SAP Cloud Connector
- SAP Analytics Cloud
Cause
This issue typically arises from a mismatch between the SAC BTP Core Account user info and the credentials used for certificate refresh in Cloud Connector. Ensure both users are identical.
Resolution
-
Access SAP Analytics Cloud.
-
Navigate to Main Menu -> System -> Administration.
-
Open Datasource Configuration.
-
Verify the email address displayed in the configuration. If the email address is incorrect, select Edit and update it with the email address associated with a valid S-user ID.
-
Save the changes.
-
Refresh the certificate in the Cloud Connector using the same email address and corresponding password.
See Also
- KBA 2397165 - How do I connect SAP Analytics Cloud (SAC) to the SAP BTP Cloud Connector and SAP Analytics Cloud Agent?
- KBA 2571763 - Authorization problem in SAP Cloud Connector when adding Cloud Foundry subaccount
- KBA 2461997 - Adding Neo subaccount to SAP Cloud Connector fails due to authorization error
- KBA 3201518 - SAP Cloud Connector Documentation
- KBA 2701137 - SAP Cloud Connector - Guided Answers
Keywords
SAC, subaccount, refresh, failed, 401, unauthorized, code 401, error, certificate renewal, manage subaccount, subaccount certificate, an error occurred when trying to connect, renew , KBA , BC-MID-SCC , SAP Cloud Connector On-Demand/On-Premise Connectivity , Problem
SAP Knowledge Base Article - Public