SAP Knowledge Base Article - Public

3062808 - Renewing SAC Subaccount Certificate: An error occurred when trying to connect — see logs for details (unless log level is 'Off')

Symptom

Error when trying to renew SAC subaccount certificate in SAP Cloud Connector.

Environment

SAP Cloud Connector

SAP Analytics Cloud 

Cause

This issue typically arises from a mismatch between the SAC BTP Core Account user info and the credentials used for certificate refresh in Cloud Connector. Ensure both users are identical.

Resolution

  1. Access SAP Analytics Cloud.
  2. Go to the Main Menu > System > Administration
  3. Click on Datasource Configuration
  4. Check the email that is displayed there. If it's not yours, choose Edit and set your email, which is associated to an S-user ID. 
  5. Try to refresh the certificate in the Cloud Connector with the same email and password.

See Also

2397165 - How do I connect SAP Analytics Cloud (SAC) to the SAP BTP Cloud Connector and SAP Analytics Cloud Agent?
2571763 - Authorization problem in SAP Cloud Connector when adding Cloud Foundry subaccount
2461997 - Adding Neo subaccount to SAP Cloud Connector fails due to authorization error
3201518 - SAP Cloud Connector Documentation
2701137 - SAP Cloud Connector - Guided Answers

Keywords

SAC, subaccount, refresh, failed, 401, unauthorized, code 401, error, certificate renewal, manage subaccount, subaccount certificate, an error occurred when trying to connect, renew , KBA , BC-MID-SCC , SAP Cloud Connector On-Demand/On-Premise Connectivity , Problem

Product

SAP Analytics Cloud 1.0