Symptom
Error: The manager [NAME] for user [NAME] does not exist or was not yet hired as of yyyy-mm-dd(date) appears during Job History Import
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Go to Admin center then Import Employee Data
- Select Job History and select incremental load/full purge (depending on the kind of import you want to perform)
- Select import file
- Click on Validation Import Data
- Result: Import failed
Error: The manager [NAME] for user [NAME] does not exist or was not yet hired as of yyyy-mm-dd.
Cause
There are two possible causes for this issue:
- "Enable Centralised Services for Job Information" is enabled in the system under Company System and Logo settings. Due to which system validates the data in the import file and finds that No hire Record in Manager/Supervisor's Job History Information.
Note: Enable Centralised Services for Job Information is universally enabled from 1H 2022 Release and can no longer be disabled in stances from this Release on. - The manager-id field visibility is View in Manage Business Configuration > Employee Central > jobInfo
Resolution
- As job information are effective dated, system validates the Manager's job information as of that date. Hence, ensure there is an hire record maintained for the Manager/Supervisor when Centralised Services for Job Information are enabled.
- Change manager-id field Visibility to 'Edit' or 'Both' as per Data Model Field Information for Employee Central - Job Information handbook.
See Also
Data Model Field Information for Employee Central - Job Information handbook.
Keywords
job history, import, centralized services, enable, job information, import employee data, manager-id, centralized services , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC , Employee Central , LOD-SF-EC-EDP-JOB , Job Information Imports , Problem