Symptom
- When you login SAP Analytics Cloud, the Welome message shows your <first name> <last name> <P number> ( For example FirstName LastName P123456 )
- You delete your account, then create a new account. After that, the Welome message shows your name with a different P number.
Environment
- SAP Analytics Cloud (Enterprise) 2021
Reproducing the Issue
- Create a new account in SAC tenant
- Receive the email to Activate Account
- Follow the steps to complete
- Log in SAC tenant.
- The Home page welcome message shows your <first name> <last name> <P number>
Cause
Your SAC tenant uses the default SAP Cloud Identity (IDP), and it shares with other SAC tenants of other customers using the same default SAP Cloud Identity. Display Name of account attribute is configured to be unique on the default SAP Cloud Identity. If another user with the same display name ( first name and last name) already exists on the default shared SAP Cloud Identity, the display name is automatically set to first_name last_name user_profile_id. user_profile_id is a random unique P number which is automatically assigned when a new user is created. It is expected bahavior.
Please refer to SAP Cloud Identity Product Document https://help.sap.com/viewer/6d6d63354d1242d185ab4830fc04feb1/Cloud/en-US/045cb01bd2034b05a69e1a626e46570f.html
Resolution
You can change and customize the Display Name.
- Login SAC tenant
- Select the icon with your picture > Profile
- Select Profile Settings
- Click the link Edit Profile & Change Password
- It will redirect you to the default SAP Cloud Identity
- Clikc Edit button. You can modify First Name, Last Name, Display Name and other setting. Display Name is the value used in the Welcome Page.
- If you get the error "The display name you have chosen is already in use. Choose a different display name", this is expected as another user with the same display name already exists on the default shared SAP Cloud Identity. Please choose a different display name then SAVE.
Alternatively, to avoid your preferred display name already occupied, you can enable and switch SAC from default IdP to your Custom SAML Identity Provider. Details can be found here.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud > Learning > Data Connections
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
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