SAP Knowledge Base Article - Public

3063654 - Incorrect Owner Name Displayed in the On Premise Overview Details Side Panel

Symptom

When changing the Owner of the On Premise (S4), via service service interface UtilitiesPremiseOverviewOut), the C4C Owner details are not getting updated.

Environment

SAP Cloud for Customer

Cause

The Owner field is not fetched from the On Premise details service. It is actually replicated from S4 during the Technical Object replication.

When the owner field is updated in S4, please check if the delta is triggered to update the premise object in C4C through Technical object replication.

This basically means that the owner Business Partner (BP) must be replicated and available in the C4C system.  If the BP nodes does not exist in C4C system, the owner field will not be updated and will remain as blank.

Resolution

You can validate this by checking:

- The Technical master data replication payload should contain the owner field.

- If the owner BP is available in C4C system.

Keywords

Utilities; Missing; Empty; , KBA , LOD-CRM-IND-UTL , Utilities , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions