SAP Knowledge Base Article - Public

3063822 - Position Upload - Error occurred while syncing the position changes to the corresponding incumbents

Symptom

Import Position data with 'Sync' parameter below error appears-:

An error occurred while the changes were being synchronized. The position and incumbents have not been updated. The error occurred while syncing the position changes to the corresponding incumbents. Please try again later. If this issue still occurs, please create a support ticket.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1. Go to Import and Export data
  2. Select Position
  3. Try upload positions file
  4. Validate- No error
  5. Now Import the file and observe the below error in Job response file-:

"An error occurred while the changes were being synchronized. The position and incumbents have not been updated. The error occurred while syncing the position changes to the corresponding incumbents. Please try again later. If this issue still occurs, please create a support ticket."

Cause

This is caused by the batch size for Position Imports. 

Resolution

To resolve the issue the batch size for position import.

This can be done by following the below steps: 

  1. Navigate to Import and Export Data 
  2. Select "Import Config"
  3. Select "Position"
  4. Change "Input Batch Size" to 50
  5. Save 
  6. Carry out large import 

Keywords

Position, Import, SYNC, Error, Sync, sync, Position to Job info sync, CS20210001628273, INC0717895 , KBA , LOD-SF-EC-POS-IMP , Position Import , Problem

Product

SAP SuccessFactors Employee Central 2105