Symptom
- Two different candidates have same user ID assigned in Employee Profile and EmployeeLogin assigned in Onboarding.
- This happens when Candidate1 is hired from RCM and Candidate2 is hired from Onboarding as Pre-Day1 user.
- Why is a single User ID being assigned to two different users?
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- Access BizX
- Navigate to Employee Profile
- Search for hired user
- View User ID
- Search for Onboarding candidate
- View User ID
- Both the hired user and Onboarding candidate have the same User ID
Cause
- This is an expected behavior. This happens when two different app servers call this API (GenerateNextEmployeeID) at the same time.
- The algorithm used in PHV step relies on GenerateNextEmployeeID SCA command to generate preday1 user id.
- The SCA command is owned by the Employee Central team and returned UserId for an existing user instead of a new User ID which is unexpected.
Resolution
Solution for this is to use a different approach to generate next Employee ID, using a database sequence. For this, we need to enable the following.
- Access BizX
- Navigate to Admin Center > Company System and Logo Settings
- Enable “Enable Database Sequence to generate next Employee ID”
To fix an affected candidate, user needs to do the following.
- Access BizX
- Navigate to Manage Data > OnboardingCandidateInfo
- Select “Take Action”
- Delete the existing userid in OCI via import using this KBA -2419074
- Raise a ticket for SAP support team to move the candidate back to PHV step.
- Support team will now move the candidate back to PHV step.
- Please complete PHV for the candidate, new OCI object will be created.
Keywords
Onboarding, Duplicate UserID, same UserID issue, EmployeeLogin, Employee Profile, Pre-Day1 User, Admin Center, GenerateNextEmployeeID, Database Sequence, API, PHV, OCI , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , Problem
Product
SAP SuccessFactors Onboarding all versions