Symptom
Calendar: appointments with duration over 24 h automatically shown as "All day" in Calendar.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Calendar work centre
- Click + to create a new appointment
- Enter 25 hours between start and end time
- Click Save and Open -> it's not marked as All Day Event
- But in Calendar it shows as All day Event
- Do the same with 23 hours -> only the actual hours are entered in calendar.
Cause
If the appointment is scheduled across multiple days - like in this case - it will be shown in the "All day" slot, as the appointment exceeds 24hrs - it will be moved to "All day" slot as the logic is based on hours OR explicitly marked as "All day".
Resolution
This is the expected behaviour and has always been like this.
Keywords
Calendar, all day, block , KBA , LOD-CRM-CAL , Calendar Control , How To
Product
SAP Cloud for Customer core applications 2102