Symptom
You receive a system exception (dump) when performing the action of sending the Sales Order confirmation to account.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Sales Orders work center.
- Select the Sales Orders view.
- Search for the ID ABC (ABC represents the ID of the Sales Order).
- Choose Edit.
- Choose Submit.
- Select Send Order Confirmation to Account.
- System is showing dump.
Also, checking the scope, you can see that the required question 'Do you want to receive sales orders electronically from your customers using Electronic Data Exchange?' is scoped.
- Go to the Business Configuration workcenter.
- Open the Implementation Projects view.
- Highlight the relevant Implementation Project.
- Choose Edit Project Scope button.
- Navigate to Step 4 (Questions).
- Expand "Sales" and then "Selling Products and Services".
- Select Option "Communication for Selling Products and Services".
- Question 'Do you want to receive sales orders electronically from your customers using Electronic Data Exchange?' is already checked/scoped.
Cause
Under the Communication Arrangement, user have changed the Application Protocol of the communication scenario linked to the business partner used in the Sales Order from XI to HTTPS.
Resolution
This is the expected system behavior.
Please change the application protocol to XI.
In this example, we will use business partner XYZ (XYZ represents the ID of the business partner used in the Sales Order).
- Go to the Application and User Management work center.
- Select the Communication Arrangements view.
- Search for the scenario linked to the business partner XYZ.
- Choose Edit.
- Navigate to the Technical Data tab.
- Change the Application Protocol to XI.
- Choose Save and Reactivate.
Now the inconsistency will no longer occur.
Keywords
Application Protocol, Communication Arrangement, Sales Order, Submit, Send Order Confirmation to Account, Dump, Exception , KBA , AP-SLO-SO , Sales Order , How To