Symptom
After creating a Maintenance Plan you have added the items with relevant data. When you try and edit the Start Date for Maintenance Item, you find that it is not editable and it is greyed out.
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
- Go to Installed Base
- Select and open relevant Maintenance Plans
- Select the Maintenance Items tab
The Start Date is greyed out and can't be edited.
Cause
Start Date will be Editable only when there is no ticket created for that maintenance item from maintenance plan and the status of the plan should not be complete.
Also Start Date is Visible only for the Time Based & Time and Counter based maintenance plans.
Resolution
In all other scenarios the start Date is not editable.
Keywords
Maintenace Plan , Item , Start Date , Edit , Editable , KBA , LOD-CRM-MPL , Maintenance Plan Processing , Problem