Symptom
After running the job to migrate JDM data to JPB following the steps provided in Help Portal, the data is still not present in the instance.
Environment
SuccessFactors Job Profile Builder
Reproducing the Issue
- o to Company Settings for your company in Provisioning.
- Go to JDM v2.0/Skills Management
- Provide username of an administrator for the migrate job in the text box.
- Select Migrate to trigger the migration job.
- Go to Monitor Jobs
- Find the JDM Old to New Sync job
- See that it is completed successfuly
- Verify that data is still missing from Manage Job Profile Content or Manage Center of Capabilities
Cause
Even though the Job is completed, if the Pre Migration check tools fail, no data will be migrated.
Resolution
Click on the details of the JDM old to new Sync job, and see if it says the Pre Migration Checks failed. In case they did, Go to Admin Center Check Tool Application-> Job Description Manager. In there, run the check tools as per described in article 2981581. There should be issues with the JDM data that prevented it from migrating, such as invalid competency descriptions, or job codes mapped to more than one role.
Once those are fixed, you can try to click the migration button again, and it should take data to JPB and Center of Capabilities.
Keywords
JDM Old to New Sync, JPB Migration, Job Profile Builder Data Migration, Missing Competencies in Center of Capabilities , KBA , LOD-SF-TIH-JPB , Job Profile Builder , How To