Symptom
This article clarifies the behavior of different browsers when opening/downloading attachments in SuccessFactors.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee Profile
Reproducing the Issue
- Log into your system via Chrome or Microsoft Edge, for example;
- Go to "Employee Profile";
- Go to a portlet that contains an attachment and click on the attachment link;
- See that it will automatically download, not allowing you to select an option to simply view it;
- Now, log into your system via Internet Explorer or Mozilla Firefox and follow the same steps;
- See that these two browsers allow you to select whether you want to open the file or download it.
Cause
This happens according to browser's setting.
Resolution
Please note that this behavior is not related to SuccessFactors system, but to each browser's setting.
So, if you try clicking on an attachment link in any other system/website/page in these browsers (Chrome, IE, Edge, Firefox), you will be able to reproduce the same scenario. Therefore, this is the expected behavior.
Keywords
Browser, Attachment, Download, Open, View, Chrome, IE, Internet Explorer, Edge, Microsoft Edge, Mozilla Firefox, Firefox, Different, Behavior, Inconsistent. , KBA , LOD-SF-EP-UI , People Profile UI (PP3 UI) , How To
Product
Attachments
Pasted image.png |