Symptom
You have attached a file to a Customer Invoice document and expected to have the attachment sent with the business document when an Output is generated.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Search for the ID ABC (ABC represents the ID of the Customer Invoice).
- Click Edit.
- Navigate to the Output History tab.
- Select the Attachments tab.
No Attachments
Cause
In order to have the attached file available for Output, you need to select the option 'Include in Output' when adding the attachment.
Resolution
This is the system expected behavior.
To have the attached file added to the Output, please perform the following:
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Search for the ID ABC (ABC represents the ID of the Customer Invoice).
- Click Edit.
- Navigate to the General tab.
- Select the Attachments subtab.
- Click Add button.
- Select File.
- New window pops up.
- Search for the expected file.
- Click Add again.
- Check the checkbox for Include in Output.
Now the attachment file will show in the Output and be sent with the business document.
See Also
2738163 - How to Include Attachments in the Output Document to Customer in Sales Quotes and Sales Orders
3058306 - Include in Output not Passing to Scheduled Invoice Request.
2794615 - Include in Output Indicator is Not Available in the Service Confirmation
Keywords
Attachment, File, Missing, Output, Customer Invoice, Include in Output , KBA , AP-CI-CI , Customer Invoice , How To