Symptom
The error "Quantity unit XXX cannot be converted to contract target unit YYY" occurs while trying to create a new Ticket as a copy of an existing Ticket.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Service work center
- Open the Ticket DEF (Where DEF represents the Ticket ID)
- Select the Actions button
- Click on the Copy option
- Error "Quantity unit XXX cannot be converted to contract target unit YYY." is raised (Where XXX and YYY denote the Unit of Measure).
Cause
When the new ticket is created, the system finds a valid Contract item that is to be assigned to the Ticket items.
However, there is no target quantity unit maintained in the Ticket item. The system fails in the attempt to convert the unit given in the Ticket item into the Contract target quantity unit.
Resolution
To resolve the error message, please do the following:
- Go to Contracts Work center
- Select the Contract and Click Edit.
- Go to Items tab
- Maintain the unit of the target quantity in the contract item.
- Alternatively, you can change the determination relevance of the contract item to None. In this case, the contract item would not be assigned to the ticket item.
Keywords
quantity, unit, ticket, contract, items, copy , KBA , quantity , contract , ticket , error , target , convert , LOD-CRM-SRP , Service Request Processing , LOD-LE-COP-SRV , Service Contract , Problem