Symptom
The value of the Extension Field XYZ is not passed to the Credit Memo, however, in the Customer Invoice it is passed correctly.
(XYZ represents the name of the Extension Field)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Select the Invoice Documents view.
- Open credit memo ABC (ABC represents the ID of the Credit Memo).
- Click on the View All button.
- Navigate to the General tab.
- You can see that the value for the extension field is not populated.
- Open Customer Invoice EFG (EFG represents the ID of the Customer Invoice).
- Click on the View All button.
- Navigate to the General tab.
- You can see that the value for the extension field is populated
You expect that the value in the Credit Memo is populated the same way as it is for the Customer Invoice since the same Extension Scenario are used.
Cause
The Credit Memo ABC was created via the Customer Return Invoice Request HIJ which is based on Customer Return HIJ (HIJ represents the ID of the Return).
For Credit Memos based on a Manual Credit Memo Request and not a Return the issue does not occur since it uses the same Extension Scenarios.
However, in this case the Credit Memo ABC is based on a Return and therefore you need to ensure that the following Extension Scenario is not active:
Customer Return - Item to Invoice Requests - Item
Resolution
To solve the issue, you need to activate the Extension Scenario Customer Return - Item to Invoice Requests - Item
See Also
KBA 2905703 - How to Work with Extension Scenarios
You can find a list of all available Extension Scenarios in the Help Center Document Extension Scenarios
Keywords
Credit Memo; Extension Field; Scenario; Value; Missing; Invoice; No Value; Return; Field , KBA , SRD-CRM-INV , Customer Invoicing , Problem