Symptom
When carrying out a Job History Import or API update with Centralized Services for Job Information enabled, fields are being set to Null or Blank after the 1H 2021 release (b2105).
When Centralized Services for Job Information is disabled the fields are being updated as expected after the import is completed.
Please Note: this is also applicable to features which update Job Information using the import framework such as Position to Job Information synchronization or Leave of Absence Record Creation.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
The below example is for a Job History Import but is also applicable for API upserts:
Instances on 2H 2021 Release:
- Via Company System and Logo Settings, confirm the below setting is ENABLED:
Enable Centralized Services for Job Information (Applicable only for data imports from UI and API. Not applicable on instances having Pension Payout enabled) - Navigate to Import Employee Data and import a Job History import
- Check a user’s profile who’s data was updated via the import
- Some fields have been set to Null/Blank
- Via Company System and Logo Settings, DISABLE the below setting:
Enable Centralized Services for Job Information (Applicable only for data imports from UI and API. Not applicable on instances having Pension Payout enabled) - Carry out step 2-3
- The impacted fields are updated with values after the import
Instances on 1H 2022 Release:
- Navigate to Import Employee Data and import a Job History import
- Check a user’s profile who’s data was updated via the import
- Some fields have been set to Null/Blank
- Via Company System and Logo Settings, DISABLE the below setting:
Enable Centralized Services for Job Information (Applicable only for data imports from UI and API. Not applicable on instances having Pension Payout enabled) - Carry out step 2-3
- The impacted fields are updated with values after the import
Cause
This is caused by a difference in processing onChange business rules with and without Centralized Services for Job Information Imports. Centralized Services for Job Information introduced in the 1H 2021 release (b2105) as an Opt-Out feature.
As documented in the following section of the Handbook: Mass Changes in Employee Central - Configuring Business Rules for Data Imports
Restriction
onChange business rules attached to fields of an HRIS entity are triggered during the import process, irrespective of whether there are any changes or not. However, this restriction isn’t applicable to HRIS entities supported by Centralized Services as onChange rules attached with such entities are triggered only when there are changes to the corresponding field values.
Resolution
Below we have advised some possible configuration changes to prevent this issue from occurring while using Centralized Services for Job Information.
Please note:
- Centralized Services for Job Information is universally enabled as of the 1H 2022 Release and can't be disabled in instance from the 1H 2022 release on.
Configuration Change:
Always True onChange Rules / Rules not checking for a change in value:
For Always True onChange Rules or an onChange rule that is not checking for a change in field value (for example location.value is equal to location.pervious value), these rules can be triggered as an onSave rule in order to propagate the field values correctly.
Please note an exception to this would be the Position to Job Information sync rule, which should never be triggered as an onSave rule in the the UI. The recomended approach here would be to use the Rule context and disable the Rule for all other contexts accept import and api.
Read Only Fields with Allow Import = No:
For read only fields (visibility = view) which have Allow Import = No, if you have not adjusted any business rules as mentioned above, in order for these impacted fields to inherit the value from the pervious record, the Allow Import setting must be updated from No to Yes.
This can be done via Manage Business Configuration for each impacted field, under the “Details” section, changing the Allow Import = Yes:
See Also
3069782 - Fields Being set to Null After Compensation Information Import/ API using Centralized Services after 1H 2021 Release
Keywords
onChange, rule, null, empty, blank, api, upsert, Enable Centralized Services for Job Information, Enable Centralized Services, Centralized Services, 1H 2021, b2105, 2105, import, rule, business rule, pos2job, position to job, loa, leave of absence , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-INT , Integrations , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Product Enhancement